May 15th 2009 Forum upgrade [Complete]

Announcements regarding the Knightmare community and website.
Post Reply
User avatar
Mystara
Administrator
Administrator
Posts: 1676
Joined: Tue Apr 22, 2003 11:53 am
Location: UK
Contact:

May 15th 2009 Forum upgrade [Complete]

Post by Mystara » Fri May 15, 2009 2:27 pm

The new forum is online and hopefully behaving well. To my knowledge, nothing was lost during the transfer. There are clearly a couple of minor issues to tidy up, but nothing that should have any significant effect on the operation of the board.

If you discover any major issues, please contact me.

frakilk
Dungeoneer
Dungeoneer
Posts: 31
Joined: Sun Oct 12, 2008 9:55 pm
Location: Malm�, Sweden

Re: Welcome back!

Post by frakilk » Fri May 15, 2009 5:34 pm

Looks great, thanks for all the hard work!

User avatar
Mystara
Administrator
Administrator
Posts: 1676
Joined: Tue Apr 22, 2003 11:53 am
Location: UK
Contact:

Re: Welcome back!

Post by Mystara » Sat May 16, 2009 9:35 am

Glad you like.

I've just spent a while upgrading the smilies and post icons too. So with a bit of luck, they'll be working properly now, without any ugly rogue white pixels.
Alan Boyd
Website: http://www.twicetwice.co.uk/

Kieran
Fright Knight
Fright Knight
Posts: 1028
Joined: Tue Nov 19, 2002 2:54 am
Location: Blackpool
Contact:

Re: Welcome back!

Post by Kieran » Sun May 17, 2009 8:30 pm

Looks very grand, sir. Hopefully everyone will be able to log back in and use its spender.

User avatar
Pooka
Fright Knight
Fright Knight
Posts: 1029
Joined: Sun Nov 17, 2002 10:55 pm
Location: London
Contact:

Re: Welcome back!

Post by Pooka » Mon May 18, 2009 7:46 pm

Information. This message has been submitted successfully, but it will need to be approved by a moderator before it is publicly viewable. You will be notified when your post has been approved.
This is not only far too reminiscent of the Host in Doctor Who, it's also far too cumbersome for the amount of people we'll have posting here. What happened to unmoderated posting access?

User avatar
Mystara
Administrator
Administrator
Posts: 1676
Joined: Tue Apr 22, 2003 11:53 am
Location: UK
Contact:

Re: Welcome back!

Post by Mystara » Mon May 18, 2009 7:59 pm

That's a very good question.
As soon as I answer it, I'll be sure to correct it.
Alan Boyd
Website: http://www.twicetwice.co.uk/

User avatar
Mystara
Administrator
Administrator
Posts: 1676
Joined: Tue Apr 22, 2003 11:53 am
Location: UK
Contact:

Re: Welcome back!

Post by Mystara » Mon May 18, 2009 8:12 pm

Okay, that should now be fixed.
Honestly, the permissions system of phpBB is an absolute mother. It has every conceivable configuration you could possibly wish for....as long as you're willing to dig around to find it and specify it exactly how you want it.

We should really move to some old obsolete measure board system like YaBB SE.

Let me know if it works?
Alan Boyd
Website: http://www.twicetwice.co.uk/

Ironlord
Level 2 Dungeoneer
Level 2 Dungeoneer
Posts: 184
Joined: Sat Jul 09, 2005 6:58 am
Location: Castle Rock
Contact:

Re: Welcome back!

Post by Ironlord » Mon May 18, 2009 8:31 pm

Testing, testing, ett, två, ett, två...

Am I still here? Had a bit of trouble with the old password dying on me. Still, it looks to be working...

EDIT: why's my text in bold and yellow?

EDIT AGAIN: it's gone back to non-bold and white. Is this a "feature" of the new board?

User avatar
Mystara
Administrator
Administrator
Posts: 1676
Joined: Tue Apr 22, 2003 11:53 am
Location: UK
Contact:

Re: Welcome back!

Post by Mystara » Mon May 18, 2009 8:39 pm

1) For reasons that completely elude me, a few people's passwords don't work and have to be reset. There doesn't seem to be any pattern. Some user accounts have worked straight away, others haven't.

My best guess is that it has something to do with capitalisation.

2) Your post appears in yellow letters when it's "selected". Probably you clicked "show my post"?
That's possibly not as obvious as it could be. Maybe I'll see if I can highlight it in some other way :-/

3) It's gone back to black-and-white because it's no longer selected :)
Alan Boyd
Website: http://www.twicetwice.co.uk/

Gizensha
Level 1 Dungeoneer
Level 1 Dungeoneer
Posts: 97
Joined: Tue Jun 29, 2004 10:38 pm
Location: Blackpool

Re: Welcome back!

Post by Gizensha » Mon May 18, 2009 11:15 pm

Loving the new layout, though poster details on the right rather than the left will take some getting used to, not used to that on any forum.

User avatar
Mystara
Administrator
Administrator
Posts: 1676
Joined: Tue Apr 22, 2003 11:53 am
Location: UK
Contact:

Re: Welcome back!

Post by Mystara » Tue May 19, 2009 6:37 am

Wasn't particularly intentional. Just how it was set up on the theme that I based this one on.
Doubtless the theme will change at some future date once we have things up and running smoothly.
Alan Boyd
Website: http://www.twicetwice.co.uk/

Naitch
Level 2 Dungeoneer
Level 2 Dungeoneer
Posts: 159
Joined: Tue Aug 23, 2005 10:53 pm
Location: London

Re: Welcome back!

Post by Naitch » Thu May 21, 2009 10:05 am

Welcome back indeed!

Like the new layout so far!

Though I too had trouble with my password not working on me... :'(

User avatar
Mystara
Administrator
Administrator
Posts: 1676
Joined: Tue Apr 22, 2003 11:53 am
Location: UK
Contact:

Re: Welcome back!

Post by Mystara » Thu May 21, 2009 10:46 am

Sadly, I currently have no idea as to the cause of the password issue. For example, the capitalisation and various login names of your account are the same as for Pooka, whose password worked first time. Unless something in the system is case-sensitive and you didn't try the magic combination that Pooka did, I have absolutely no ideas as to what might have occurred.

The only thing I can do (in general) would be to reset everyone's passwords. However, there's a possibility that this might have to happen as a one-off in the future. So I'm avoiding having to do it twice :)

For the record, if anyone is having issues logging in, you should try the following:
1) Try logging in with both your login name and screen name (which may have been different). The screen name is the name which your posts are labelled with. The login name is the name you used to log in to the forum.
2) Try entering your login name in lower-case if it isn't already.
3) The next thing to try is the password reset link: http://knightmare.com/forum/ucp.php?mode=sendpassword which will reset your password and send the new password to your registered email address.
4) If you no longer control your registered email address, and you missed our previous requests to update your account with your current address, you'll have to request assistance at the following page: http://www.knightmare.com/contact.htm.

If anyone has any suggestion as to why their login did/did not work, I'd love to hear it. As far as I am aware, it shouldn't be a matter of randomness. There should be something specifically different for those whose logins work versus those whose logins do not work.
Alan Boyd
Website: http://www.twicetwice.co.uk/

User avatar
Mystara
Administrator
Administrator
Posts: 1676
Joined: Tue Apr 22, 2003 11:53 am
Location: UK
Contact:

Re: Welcome back!

Post by Mystara » Tue May 26, 2009 8:06 pm

Okay, I think the password problem is solved.
Sadly, I have no account on which to test this, though :(

Hopefully future logins can be made using your old forum login/password. If not, let me know!

Edit: Seems to be so far, so good. Looks like the bug is solved.
Alan Boyd
Website: http://www.twicetwice.co.uk/

Illusion
Knight
Knight
Posts: 633
Joined: Fri Jan 11, 2002 3:01 am
Location: Corridor of Blades
Contact:

Re: Welcome back!

Post by Illusion » Fri Jun 05, 2009 7:20 pm

No problems to report here. Okay, I've only just got round to posting my first message on the new design forum! Good work.

Post Reply